Take the 2-minute tour ×
Information Security Stack Exchange is a question and answer site for Information security professionals. It's 100% free, no registration required.

Metasploit (msf) doesn't see exploits from exploitdb. I've just updated directory on my Backtrack

cd /pentest/exploits/exploitdb
svn update

How can I load them now into msf? When i use a script searchsploit <name> I can find what I need, but I don't know how to load it inside msf.

share|improve this question
    
Wouldn't it make more sense to be using msfupdate? –  Polynomial Jan 21 '13 at 15:11
    
Maybe it would. I just thought I can load exploit from that dir. –  Simon Jan 21 '13 at 19:35
add comment

2 Answers

Metasploit develop their own exploit database. You cannot simply load a random exploit from ExploitDB into Metasploit.

share|improve this answer
    
Are you sure, that I cannot load exploits from that directory into metasploit? Can I use them in any other tool? I'm just exploring backtrack and I can't find docs about that exploits... –  Simon Jan 21 '13 at 19:38
1  
Yes I am pretty sure ExploitDB exploits cannot be used in Metasploit (unless the Exploit is specifically developped for Metasploit framework). –  lisa17 Jan 22 '13 at 8:56
add comment

In short, doing an 'msfupdate' will get you the latest Metasploit-compatible exploits. The developers do a good job of including modules from 3rd parties, so it's safe to say that this will get you most of the public modules.

As other posters have indicated, Metasploit requires a specific format to utilize an exploit. Metasploit exploits are often (always?) posted on ExploitDB, but are almost always included in the framework itself as well, so loading an exploit from ExploitDB using the 'loadpath' command won't do much good.

Any exploit is theoretically Metasploit compatible, but will need to be ported. This is a decent place to start: https://community.rapid7.com/docs/DOC-1275

There are some beginnings of public 'exploit packs' for metasploit, check out Mubix's 'q' if you're interested: https://github.com/mubix/q - Though these modules are often incomplete or broken for various reasons, much like the 'unstable' branch of the metasploit-framework: https://github.com/rapid7/metasploit-framework/tree/unstable/unstable-modules

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.