Take the 2-minute tour ×
Information Security Stack Exchange is a question and answer site for Information security professionals. It's 100% free, no registration required.

Problems configuring Webscrab to intercept traffic from localhost(Webgoat).

I am trying to go through the Webgoat tutorial and at one point I need to use Webscrap. I configured the proxy though Firefox and I added the LAN settings in Windows, but it still doesn't work.

I can't find a solution on-line, I think I tried everything.

Firefox Configuration: enter image description here

Windows LAN settings:

enter image description here

This is the file I run for Webgoat

enter image description here

This is the file I use for Webscrab enter image description here

If I try to access the Webgoat through this link, webscrab does not intercept anything

http://127.0.0.1:8080/WebGoat/attack

If I try to access webgoat through this link, the traffic is intercepted, however it says that the page is not found (Error 404)

http://127.0.0.1./webgoat/attack

I can't a solution on line so I hope here anybody knows how to make it work.

Thank you

share|improve this question

closed as off topic by Terry Chia, Polynomial, Rook, Scott Pack, Rory Alsop Feb 17 '13 at 22:03

Questions on Information Security Stack Exchange are expected to relate to Information security within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
in the firefox screenshot you have the default which is to bypass proxies for 127.0.0.1 . Try taking that out. –  Rоry McCune Feb 16 '13 at 8:12
    
And I think you have to decide for one port: 8080 or 8008. –  migg Feb 16 '13 at 19:11
1  
This is not a security issue, it is purely a configuration issue (as @Rook described below). Closed as off-topic. –  Rory Alsop Feb 17 '13 at 22:03

1 Answer 1

up vote 4 down vote accepted

In your first sceenshot it says:

"NO Proxy For" and it lists 127.0.0.1 and localhost.

Then you are trying to access webgoat on localhost... Perhaps you should look over your configurations more carefully in the future.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.