Take the 2-minute tour ×
Information Security Stack Exchange is a question and answer site for Information security professionals. It's 100% free, no registration required.

I've found this vulnerability (http://www.metasploit.com/modules/exploit/multi/http/jboss_invoke_deploy) but can't seem to set proper values for exploit to work , payload shown on site gives me worn payload error.Thanks

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

You have not provided the exact error message but I believe you might be using the wrong payload. For example, executing a payload designed for Windows on a Linux setup is surely going to fail. If you are not sure what environment the JBOSS is operating in, use the Java meterpreter payload. It will execute on all the supported platforms. The page you have referred provides an example of using windows/meterpreter/reverse_tcp payload. There is a meterpreter payload for Linux as well as java.

Linux payload is unix/meterpreter/reverse_tcp Java payload is java/meterpreter/reverse_tcp

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.