Take the 2-minute tour ×
Information Security Stack Exchange is a question and answer site for Information security professionals. It's 100% free, no registration required.

To prevent adds and pop-up that seduce users to install or download viruses I have disabled Java. But I have noticed that even with Java disables Firefox is still running it. The pop-ups are coming up. I even tried switching it to Private Mode just to see and ti still allowed the Java to run. This happened since the last update. Anyone out there have an answer? Is this a bug in Firefox or is Java running some new script that can't be disabled? Or is there another browser out there that is more secure?

share|improve this question
4  
Is it possible that you are confusing java and javascript? –  razethestray Aug 22 '13 at 13:20
    
I may well be. I am not really a security IT guy. This has just been kind of thrown on me and I am trying to make it as secure as I can without just locking everything down. If this is the case do you have any advice? –  Will Aug 22 '13 at 13:36
1  
What operating system and how exactly did you disable it? Unless you disabled it through the Control Panel Applet on Windows then you didn't disable it right. We are talking about Java not Javascript right? –  Ramhound Aug 22 '13 at 13:52
    
This doesn't sound like either a Java or Javascript issue to me. This sounds like adware. –  Xander Aug 22 '13 at 13:55
add comment

closed as off-topic by Xander, AJ Henderson, Adnan, NULLZ, AviD Aug 22 '13 at 14:54

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about general computing hardware and software are off-topic here, but can be asked on Super User." – AJ Henderson, AviD
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Java and JavaScript are not the same. They aren't even related. JavaScript is an interpreted scripting language that is used by websites to automate site behavior and interactivity on the client side. Java is an actual computer language that is run by a Java Virtual Machine (JVM) and is used for applications or occasionally applets that may be embedded into a website. JavaScript is what is disabled by the browser. For Java you would need to change the settings for the Java add-in for your browser. It will be called "Java Platform something-or-other", depending on your version when in Firefox.

Update: If these are disabled or not installed already, then you probably already have adware on your system that is causing the pop-ups by actually asking the browser to load them directly. Try running something like Malware Bytes to see if it finds anything.

share|improve this answer
    
It is the 23.0.1 and there are no Java Plugins to disable. I am at a loss to know what to ask next. –  Will Aug 22 '13 at 13:51
    
@Will - if you can post a screen shot of the popup that would help. –  AJ Henderson Aug 22 '13 at 13:56
1  
I think the correct thing to do a that point is not post a screenshot or mess with the system but get the (direct) help from someone how knows what he is doing: contact your system administrator –  Stephane Aug 22 '13 at 14:24
    
OK thanks to all the post. Yeah I have tried all of this now and it is still happening. I will install Malware Bytes and try that. I never thought of a virus doing it. Thanks again. !! –  Will Aug 22 '13 at 14:50
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.