Information Security Stack Exchange is a question and answer site for information security professionals. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've started working with ettercap and ARP-poisoning; however, I've sumbled upon some problems. I've executed the following command:

ettercap -i wlan0 -w log -T -M arp:remote / /,86-253,255/ is the gateway, is my own internal IP address.
It starts sniffing but I'm not receiving any packets, I've tried to capture my own traffic which works.
What's the problem? I've specified ip_forwarding using echo 1 >> /proc/sys/net/ipv4/ip_forward .

share|improve this question
Can you inspect the target arp cache to see if the arp poison actually worked? – Dog eat cat world Nov 11 '11 at 23:17
Just because it supports mon mode doesn't mean it's actually in mon mode. I would start with that. Also it's likely channel hoping by default. You want to focus on a channel as well. – Anthony Russell May 27 '15 at 13:07

It depends on your WiFi chip. Some chips to not support promiscuous mode. For many chips, you can get special drivers that enable promiscuous mode. You can search on the aircrack-ng for drivers that support your chip, or you can get a $10 USB WiFi device that works better.

share|improve this answer
I've got a RaLink 2860 chipset, if I'm not mistaken I think RaLink makes some pretty decent chipsets. I couldn't find any information about it on this site though. Do I have to put my interface in monitor mode for this to work? I thought it only applied when cracking networks and I didn't find anything when I read the documentation for ettercap. I'll give it a try nevertheless. Thanks for answering. – Griffin Nov 11 '11 at 16:14
Unfortunately some good chipsets aren't supported, while some cheap ones are. As Robert says you just need to find the right ones. – Rory Alsop Nov 11 '11 at 16:58
Alright, thanks to you both. I'll see if I can get my hands on a supported chipset and try again. – Griffin Nov 11 '11 at 19:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.