123 reputation
4
bio website roguelite.blogspot.co.uk
location United Kingdom
age
visits member for 2 years, 1 month
seen Jul 10 at 15:55

I am a professional software developer based in the UK.

I'm developing an indie game. http://roguelite.blogspot.co.uk/


Jul
6
comment Is it a security risk to maintain an application developed for a version of .NET prior to 4.0?
I'm glad you didn't have any issues, but I can't for the life of me get Crystal Reports which work in VB6 / .NET 1.1 to work in a .NET 4 compiled app without resaving them in an newer format. For reasons I won't go into, it's not feasible to upgrade all our reports at this time.
Jun
13
awarded  Supporter
Jun
13
awarded  Scholar
Jun
13
accepted Is it a security risk to maintain an application developed for a version of .NET prior to 4.0?
Jun
11
awarded  Student
Jun
11
comment Is it a security risk to maintain an application developed for a version of .NET prior to 4.0?
In an ideal world, no we wouldn't have to change any code. But there are issues with 3rd party APIs such as Crytal Reports and the SAP Connector which prevent the projects being upgraded quite so easily. I'm more interested in whether the earlier frameworks have any known vulnerabilites that would cause security concerns when deployed. e.g. if I had .NET 1.1 on a server is it a security risk?
Jun
11
asked Is it a security risk to maintain an application developed for a version of .NET prior to 4.0?
Jun
11
awarded  Autobiographer