3

Can someone help me in explaining this:

I have an old and expired GPG key, on my keyring the key lists correctly as expired:

myself@mypc:~$ gpg --list-sig --fingerprint DDF70E72
pub   1024D/DDF70E72 2010-12-01 [expired: 2015-01-01]
      Key fingerprint = 2D26 5D20 103A 16D6 4561  E107 D4B2 92C0 DDF7 0E72
uid                  My Name (4 apr 1965) <mymail@mydomain>
sig 3        DDF70E72 2014-11-29  My Name (4 apr 1965) <mymail@mydomain>
sig          2D4527DC 2010-12-25  [User ID not found]
sig 3        DDF70E72 2010-12-01  My Name (4 apr 1965) <mymail@mydomain>

While on keyserver the key appears as not expired:

Search results for '0xddf70e72'

Type bits/keyID     cr. time   exp time   key expir

pub  1024D/DDF70E72 2010-12-01            
     Fingerprint=2D26 5D20 103A 16D6 4561  E107 D4B2 92C0 DDF7 0E72 

uid My Name (4 apr 1965) <mymail@mydomain>
sig  sig3  DDF70E72 2010-12-01 __________ 2015-01-01 [selfsig]
sig  sig   2D4527DC 2010-12-25 __________ __________ []
sig  sig3  DDF70E72 2014-11-29 __________ 2015-01-01 [selfsig]

sub  2048g/D40BC0B4 2010-12-01            
sig sbind  DDF70E72 2010-12-01 __________ 2015-01-01 []

Can someone help me in understanding why?

2

Have you tried pushing your updated key to the keyserver? The main reason that your copy of the key and the one on a keyserver would differ is that you changed the expiration date of your key on your local machine after pushing it to the keyserver. See https://www.gnupg.org/gph/en/manual/x457.html for help if you need to update a key. Once you update the key on the keyserver, the keyserver should begin distributing the updated key to users looking for your key.

Alternatively, if you no longer wish to use that key, you could revoke the key and publish a revocation certificate to the keyserver.

  • Tried (via web upload and via --send-keys command but no success. Since the expiry date in signatures has been correctly updated I have figured out that the upload worked. But, the key is still listed without the red string exp as other expired keys – Alessandro Carini Oct 3 '15 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.