-1

The scenario is as follows: while a PC was connected to our company's network, a specific application was able to open another process on a predefined port. It worked as expected.

But now, this PC has traveled to another location and so, it's being connected to another network at this moment. Our needed process can't be opened on its well known port.

Before trying to get rid of that other process and move all the code from there in our main app to eliminate the need of the child, i want to know if that network connection over there can influence the steps of opening a port on the PC.

closed as off-topic by user45139, Deer Hunter, schroeder Oct 10 '15 at 14:42

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Information security within the scope defined in the help center." – Community, Deer Hunter, schroeder
If this question can be reworded to fit the rules in the help center, please edit the question.

  • When you say "Our needed process can't be opened on its well known port." do you mean that the application is throwing you an error saying that the process of Socket Creation failed or do you mean that the applications tatrts but isn't reachable from other hosts? – davidb Oct 9 '15 at 11:05
  • @davidb, i've checked with netstat -aon | find "9998" and i got no response... so, the secondary process is not even started.. and no other process resides on 9998. To conclude.. Socket Creation seems to be the case.. – Olaru Mircea Oct 9 '15 at 11:10
1

There are a few things that can cause this. Connection problems can be caused by a firewall which blocks all ports beside some that have explicitly been enabled. This is called whitelisting and can possibly cause this problem.

Two other posibilities that came to my mind are:

  • In the new network you got an new IP but the socket tries to bind itself to the old IP-Address
  • When the new network provides a domain your user might not have enough rights to start a Socket on a Well known port because this requieres admin rights
  • It seems so strange to me because it worked here, connected to our routers, but when changed the location and implicitly changed the network connection it stopped working.. – Olaru Mircea Oct 9 '15 at 11:22
  • 1
    Have a look at the part of your code where the socket is created. Once I wrote a serverside appplication and it stopped working because I did bind the socket to a hardcoded IP-Address. – davidb Oct 9 '15 at 11:24
  • I upvoted the answer because you gave me a lead.. i will continue the investigation and come back to accept it because i am sure the issue is somewhere near your advice. Thanks a lot! – Olaru Mircea Oct 9 '15 at 12:09
  • Your welcome. If you need any further advice dont hesitate to ask! – davidb Oct 9 '15 at 12:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.