4

I have a problem with implementing this attack.

I have a kali linux machine on vmware workstation. My router is - 192.168.1.1 My victim ip is - 192.168.1.254

arpspoof -i eth0 -t 192.168.1.1 192.168.1.254

arpspoof -i eth0 -t 192.168.1.254 192.168.1.1

I changed

/proc/sys/net/ipv4/ip_forward to value 1.

And after check arp -a on victim machine the mac address of the router still the same , and if i ping some ip even to my router i get requested timed out on victim machine CMD.

closed as off-topic by Rory Alsop Dec 31 '15 at 10:41

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Information security within the scope defined in the help center." – Rory Alsop
If this question can be reworded to fit the rules in the help center, please edit the question.

  • The problem isn't from the attack itself, try the attack on another victim, from another machine, or even change the IPs. sometime it fails for no reason! ... and let the arpspoof runs for several minutes. – Emadeddin Oct 29 '15 at 13:33
  • Have you launch the two commands in the same time ? – Sorcha Oct 29 '15 at 13:33
  • @Emadeddin I changed the ip to 192.168.1.19 and it is still does not work. let the arpspoof run ? Ok i will try it .. its the first time things like that happend – Antonio Oct 29 '15 at 13:39
  • @Sorcha Within a few seconds. – Antonio Oct 29 '15 at 13:39
  • Check the victim is seeing it (can't see why it wouldn't but we all know what assumption is the mother of) with tcpdump or similar, or at least check it is being sent by the attack machine. – Michael Oct 29 '15 at 13:58
0

As a result from the comments, the problem is solved by changing the working interface from WiFi to Ethernet.
the connection was made through the host's WiFi card, but the VM sees it as Ethernet card, and that caused compatibility issues.

Use a USB WiFi adapter will help you avoid that kind of problems on virtual machines.

  • When i think about it on wifi network the linux not should show me wlan0 ? – Antonio Oct 29 '15 at 17:25
  • No. on virtual machines the wifi card is showed as ethernet card, you must install Kali as a native OS so the wifi card appears as wlan. or you can use a USB wifi card. – Emadeddin Oct 29 '15 at 17:29
  • So what was the problem ? with network cable it works. – Antonio Oct 29 '15 at 17:52
  • Compatibility issue. – Emadeddin Oct 30 '15 at 6:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.