1

This morning I was reading some news on some websites (I think one of them was haaretz.com) using my iPad (ios 9.0.1), I clicked on a news and I was redirected to some dodgy website and I started getting all kind of popups. I killed the tabs but I keep getting these popups and auto-opened tabs on all the browsers (even facebook app)

How can I remove these? How dangerous do you think they are? At the moment it looks like it's a form of malicious advertising for all kinds of things.

EDIT: Cleared both history and website data, rebooted iPad, visited only bbc and the pop-ups are still appearing

Examples:

enter image description here

enter image description here

4
  • 3
    This look like "scare-ware" JavaScript pop-ups designed to scare you into installing fake AV apps.
    – Burgi
    Nov 25 '15 at 13:56
  • Have you rebooted the iPad?
    – Burgi
    Nov 25 '15 at 14:30
  • 1
    Could it be some sort of DNS hijack on your router? Does it happen on other devices on your network? Have you checked the DNS settings for the iPad?
    – JonnyWizz
    Nov 26 '15 at 10:42
  • I'm sorry this has happened to you, but we aren't tech support or a virus remediation site. This might be a question for Apple.
    – schroeder
    Nov 26 '15 at 17:43
4

At the moment it looks like it's a form of malicious advertising for all kinds of things.

Yes, more than likely these are on the sites themselves and not on your iPad. Close all browser tabs and try browsing sites without popup advertising. E.g. google.com and bbc.co.uk (no adverts when accessed from UK however I believe they carry non-intrusive ads for foreign visitors). If these warnings don't popup on known "safe from bad ad" sites then it is more than likely scareware ran by advertisers on the sites you visit.

If the popups are still happening then it could be your local network or ISP. Try against a trusted HTTPS site and also from a different Wifi network.

2
  • Tried but the popup ads come from everywhere on every browser
    – spauny
    Nov 26 '15 at 14:43
  • @spauny Check the setting of your iPad and make sure no proxy or any network "profile" is set. Then check the DNS to make sure it is your router or whatever your ISP assigns. Then check your router to make sure its DNS is pointing to the ISP's. You can google about how to do these.
    – billc.cn
    Nov 26 '15 at 16:51
1

What I would do is:

  1. Close all apps in the App Switcher.
  2. Close all tabs in Safari.
  3. Ensure "Block Pop-ups" is enabled in Settings > Safari and "Clear History and Website" while you're there.
  4. Go to Settings > General > Device Management and delete any profiles you don't recognize.
  5. Clear the RAM on the iPad. Hold down the power button until the "Slide To Power Off" appears, then hold the home button down until that disappears.
  6. Restart your iPad.
  7. Go to Settings > General > Reset and tap "Reset All Settings".

If you've already done all of the above without success, you'll need to restore your iPad. All data will be deleted on your iPad (some should be safe in iCloud, like documents, photos, videos, paid apps, iTunes content, and more, but just check so there's no surprises).

  1. Go to Settings > General > Reset and tap "Reset All Settings". This will erase all data on your iPad
    1. Set up as a new iPad or restore from a backup with iTunes (just ensure that it's old enough to not contain the popups).
0

Try going into Settings > Safari, and look for "clear safari" or "reset safari" or something like that. It should clear all cookies, stopping the popup.

6
  • Nope, did this already and it didn't work. Also the popups appear on other browsers as well as facebook app
    – spauny
    Nov 25 '15 at 14:12
  • 1
    @spauny The Facebook app uses the Safari engine
    – FireFaced
    Nov 25 '15 at 14:20
  • @spauny did you clear both history and website data? Nov 25 '15 at 18:09
  • 1
    This answer shows a fundamental misunderstanding of how cookies work...
    – billc.cn
    Nov 26 '15 at 16:52
  • @billc.cn Well, maybe not COOKEIS exactly, but anything in the history that's opening it up.
    – FireFaced
    Nov 26 '15 at 20:53
0

Make sure that you have closed any 'Private Browsing' tabs as well, as this could be getting loaded in from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.