4

I was able to log into various stack exchange sites with no problem, but as of today 1/5/2016 I'm getting the following error message with firefox 43.0.2:

You have asked Firefox to connect securely to security.stackexchange.com, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

...

security.stackexchange.com uses an invalid security certificate. The certificate is not trusted because it was signed using a signature algorithm that was disabled because that algorithm is not secure. (Error code: sec_error_cert_signature_algorithm_disabled)

Firefox gives me the option to add an exception if I understand the risks. The problem is that I don't understand the risks. Is this problem unique to me? How can I fix this? (I've disabled all extensions in Firefox, but that didn't help. I'm posting the question as a guest since I couldn't log in.)

Update: as suggested in the comments, I checked the issuer of the certificate and it was "avast! Web/Mail Shield Root". After updating Avast to its latest version, the problem went away. Thanks everyone.

  • Are your computer's date & time settings correct? Also, this may be of some help... superuser.com/questions/964142/… – Marc Woodyard Jan 5 '16 at 9:30
  • 1
    I don't get an error message. It is possible that there is a transparent proxy between you and StackExchange (with its root certificate installed on your machine). If this proxy is configured to sign the certificates using SHA-1, that would explain the error message, because the "Valid from" field on the certificate used on StackExchange is January 4, 2016, and Firefox doesn't accept certificates that are signed with SHA-1 with a "Valid from" date after January 1, 2016. Who is the issuer of the certificate you see? – user3409662 Jan 5 '16 at 9:33
  • I think the problem is with my anti virus. The issuer of the certificate is "avast! Web/Mail Shield Root". I'll try to solve this and would report back shortly. – mhp Jan 5 '16 at 9:49
  • I updated my my anti virus (avast) to the latest version and the problem went away. Thanks every one! – mhp Jan 5 '16 at 9:58
  • 3
    Problem went away? I suggest the error message went away, but if your Ant-Virus is carrying out an invisible MITM on your SSL connections, then you have a very different problem. It would be nice to think that products sold to enhance the security of a system did actually enhance the security of a system, unfortunately that's not always the case. – symcbean Jan 5 '16 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.