2

I've noticed when I visit dnsleaktest.com using Windows 8.1 & Chrome a bunch of UK IP addresses (Belonging to my ISP) are displayed alongside the Netherlands IP address I should be appearing as (see below)

enter image description here

When I do the same thing on Ubuntu 15.10 & Chromium (pretty much straight out the box installation) I do not get the same issue (see below)

enter image description here

I've tried following several sets of instructions including the ones on the website I used to do the test (e.g. manually setting DNS address). Of note on a different computer running Windows 10 the same thing occurs and we have not managed to resolve it.

This is my first question hopefully I've not breached anything! Thanks in advance.

5
  • The most likely scenario is that you simply didn't follow the instructions on the page exactly as described. Please recount the exact steps you have taken in order to verify or disprove this theory. Jan 14 '16 at 8:56
  • What I've done is: (i) Connect the VPN. (ii) Flush the DNS cache with ipconfig /flushdns. (iii) Set the DNS server statically to 10.4.0.1, which is the one AirVPN says it is using. (iv) Start up a browser and run the test. I've re-run these steps and am still seeing IP's from my DNS. What is confusing me is that I have not had to do anything like this under Ubuntu it essentially worked out of the box. Lowest common denominator I have is that Windows has something to do with it?
    – 0zero
    Jan 15 '16 at 7:36
  • The page says to set the DNS servers statically before connecting to the VPN (but also contradicts itself in method B). It also says to set the DNS servers to 0.0.0.0. However I don't really see how that would help to be honest. Are you sure that you're setting the correct network interface? Jan 15 '16 at 15:09
  • If you try to set it to 0.0.0.0 I get an error, whereas if you replace it with the airvpn dns IP it doesn't complain. I assumed it was just a wildcard to replace after a bit. I've tried doing it through command line and also through the network connections GUI as well. I'm using the wifi and there is only one wifi interface available. I'm quite sure I'm doing it on the right one.
    – 0zero
    Jan 16 '16 at 21:50
  • If you statically set the DNS servers using the network adapter properties and only use that network adapter for your Internet connection then only those DNS servers specified should be utilized. However extenuating circumstances may complicate the DNS setup on your computer. For example, when connecting to the VPN, the VPN client application may choose to initialize another internal IP address on your network which would initiate another DHCP request and the software may in turn end up forwarding DNS requests to the DNS servers advertised by your router/ISP via DHCP that way. Jan 16 '16 at 22:39
1

The problem may be windows 8 (and windows 10) using 'Smart Multi-Homed Name Resolution'. This basically sends queries to multiple DNS servers and returns the fastest result, so your network adapter's DNS may not have been used.

You can try using gpedit to disable this, avast have some instructions here

If this setting does not appear in gpedit (I have seen it missing!) you can manually change the registry to disable it.

Go to the key (create DNSClient if it does not exist): HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows NT\DNSClient

and create a DWORD DisableSmartNameResolution. Set it to 1, and then flush your DNS cache.

This is explained in more detail in the article here

1
  • Success! We're down to just the one address, which is the one it's supposed to be.
    – 0zero
    Jan 18 '16 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.