0

I'm testing out hydra, for this purpose I started sshd on a Raspi with Kali 2 running as a target machine. The attacker is a Kali 2 VM on a Macbook. I verified that connecting manually via SSH to the target works.

Now I generated a password list of several thousand permutations with john the ripper's rule option, then reduced it with pw-inspect (to those with at least 8 characters). They all follow the same rules, e.g.:

Peter1234!
Peter1234%
Peter1235!

and so on.

Now I made sure the correct password is in this file. However, when I run hydra it reports in the end that it could not find the password. If I reduce the list in volume to about 30 entries around the correct pass it will work.

I'm at a loss what the reason might be and this way I can't pentest since I will not know if the password has really not been found or if it's my problem.

1

By default THC-Hydra does not have SSH support and unless you install ALL of the following libraries it will behave exactly as you describe.

libssl-dev libssh-dev libidn11-dev libpcre3-dev libgtk2.0-dev libmysqlclient-dev libpq-dev libsvn-dev firebird2.1-dev libncp-dev libncurses5-dev

More specifically if you install all the libraries at once you won't see the failure of one of them in the middle followed by the last few succeeding. Problem I run into frequently when installing it on different systems.

If you install each one of these libraries one by one you can catch which one didn't install correctly, correct it, and then Hydra will start working again.

Finally also ensure that you use the following syntax with the port number at the end after the IP address IP:Port

hydra -l testuser007 -P top500.txt ssh://184.100.123.123:22

  • Thanks, I just tried this and many were missing. I could install all except libncp-dev. I got "E: Unable to locate package libncp-dev". Can someone help me with where I can get this package, any rep I have to add for Kali 2 to find this package? I'll now try scanning without this package, after all a few were missing and I got them now. – Draugr Feb 17 '16 at 20:18
  • Didn't work either. I also just wondered why would it work with a short list if all these libraries were missing? – Draugr Feb 17 '16 at 20:29
0

You can try to use patator which is more reliable than Hydra. https://github.com/lanjelot/patator

  • Thanks, I'll check this out in any case, since I didn't know it before. – Draugr Feb 17 '16 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.