2

Recently Google discovered the "glibc getaddrinfo" vulnerability (CVE-2015-7547)

Is this a server side only issue, or can apps be affected by it as well? I'm developing both an iPhone and Android app, and don't know exactly what to look for, or what to update.

Thanks

5

Neither Android nor iPhone use glibc, so these are not affected. Android uses as libc Bionic and iOS is also using their own libc implementation.

  • Not even by using a library like AFNetworking or something like that? – Jan Feb 23 '16 at 19:41
  • 1
    @Jan: no, not even then. – Steffen Ullrich Feb 23 '16 at 20:29
  • 1
    Google wrote their own library that wraps the libc type stuff, Bionic. – RoraΖ Feb 23 '16 at 20:31
  • Ubuntu Touch is affected, for example. The update is scheduled for today. – Andrey Sapegin Feb 24 '16 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.