0

CVE-2015-7547 vulnerability, its mentioned,version of glibc below 2.23 are vulnerable.

if the glibc used is below 2.23 , but application does not uses getaddrinfo() function, Is the application still vulnerable?

1 Answer 1

3

While you might not use the function in question, some other library function might use is somewhere, which potentially opens the vulnerability for exploit.

It is therefor hard to know without actual (pen-) testing whether your application is vulnerable to this vulnerability.

1
  • 2
    For example - the package manager relies on DNS, and may use the getaddrinfo() function from glibc.
    – mti2935
    Commented Mar 1, 2016 at 14:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .