2

My Ubuntu 12.04LTS system currently offers OpenSSH_5.9p1 Debian-5ubuntu1.8, OpenSSL 1.0.1 14 Mar 2012. Besides being old, it does not allow me to use e.g. the option

# PubkeyAcceptedKeyTypes ssh-rsa*

in sshd_config, or the option -o in ssh-keygen. I guess the alternative would be to compile from source the latest version, with the drawback of having to do manual updates everytime.

How secure is such a system, namely would it be moderately safe to run it on a home machine behind a router with private IP, where port 22 is mapped to the desired private IP?

  • Can't you update the system? – Neil Smithline Mar 9 '16 at 16:57
  • @NeilSmithline well, Ubuntu 12.04 with full updates features that version; if you mean upgrade to 14.04 or 16.04, then I might consider it, but my question still stands, as exactly I'm considering whether it's worth the time and effort or not – jj_p Mar 9 '16 at 18:28
  • 1
    Didn't understand that you were using an Ubuntu release that still has support for security patches. – Neil Smithline Mar 9 '16 at 19:02
2

Well if your system has a private ip and is behind a router (using ipv4,nat and firewall). Considering you are also not running a natted server.

You may be considered a bit safe from my opinion , though other attacks (like after packet manipulation may be possible,etc) Than it would depend how much securily your router is configured.

At last you can check for vulnerablities for older packages (Openssh,Openssl) ,also for your linux-version from sites like cvedetails.com. Apply patches or upgrade your package according to your necessity.

| improve this answer | |
  • maybe I did not explain myself correctly: the provider gives me 1 public IP, which is associated to the router; then my PC gets a private IP from the router, but still for example port 22 is mapped to the PC, so that ssh can work. You say that I'm moderately safe with that old ssh version? still I believe it gets all security patches, but there will be some difference with the most updated openssh version – jj_p Mar 10 '16 at 18:58
  • 1
    Port-22 is mapped to the pc then i guess you are running a ssh natted server. that means enabling port forwarding in your router (i guess again). In that case you will be more vulnerable as people will directly connect to you.Best way is to upgrade your package and apply strict firewall rules. – sourav punoriyar Mar 11 '16 at 5:22
  • Yes new ssh will come with new features, and more security. – sourav punoriyar Mar 11 '16 at 5:26
  • you guess correct – jj_p Mar 11 '16 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.