3

I want to do De-auth attack on Ubuntu 14.04 using Aireplay-ng. I am using alfaawus036h, so when I tried it on Kali or Backtrack, after plug in, it worked fine and there was no problem. but when I tried on Ubuntu, it didn't work properly. After some errors like fixed channel -1, Aireplay-ng works like this:

Sending 64 directed DeAuth. STMAC: [xx:xx:xx:xx:xx:xx] [0|0 ACKs]

,but there was no effect on the network.

I thought that maybe Alfa card should have proper drivers to work perfect, so i used katoolin for adding Kali repositories on my Ubuntu 14.04. but after using sudo apt-get install aircrack-ng and running the aireplay-ng, i couldn't solve the problem, any help? thanks!

============ EDIT: After two Sending 64 directed DeAuth. STMAC: [xx:xx:xx:xx:xx:xx] [0|0 ACKs] it shows network is down and my interface will be disabled!

How can i be sure that all drivers for Alfa card are installed properly on my Ubuntu?!!

7
  • Did you make sure to run airmon-ng check kill before running aireplay-ng? Apr 4, 2016 at 14:28
  • yes, one of my problems solved using check kill...
    – lord.h
    Apr 4, 2016 at 14:28
  • i want to know what should i do exactly to perform this attack properly on Ubuntu?
    – lord.h
    Apr 4, 2016 at 14:30
  • 1
    Any reason you want to run this on Ubuntu as opposed to a live Kali session? Would require a lot less troubleshooting. Apr 4, 2016 at 14:44
  • 1
    Driver installation questions need to be asked on another site, not here.
    – schroeder
    Apr 4, 2016 at 15:19

2 Answers 2

1

Checklist to verify:

  • AppArmor - profile and logs, there can be interfering rules.
  • SELinux - same as above. Try disabling both as a dummy solution. If it still does not works - then first two options are no way in dealing problem. But I saw cases when they did
  • use ldd <command> and compare libs versions from Kali and Ubuntu. If Ubuntu - especially LTS - has an old ones, make a source compilation at Kali with full static binary - and use this binary on Ubuntu. It is the easiest way to fix this issue in Ububtu
2
  • 1
    I need more explanation about AppArmor and SELinux, but maybe can find it by googling! :) thanks!
    – lord.h
    Apr 4, 2016 at 14:48
  • @lord.h these application security suites can limit in their configs(thet're called profiles) not just FS permissions, but network activities too. If the "network part" is not written in configs - they're not limiting it, but keep in mind that devfs rules can be limited by FS rulesets. Sometimes an application is even writes no logs about inabilities to make something with device tree. Feel free to ask! Apr 4, 2016 at 15:40
1

network is down because you used the command airmon-ng check kill and so you stopped the network-manager application.

Don't use the previous command to fix the fixed channel -1 error, instead, use the following commands when starting monitor mode:

  • airmon-ng start wlan0
  • ifconfig wlan0mon down
  • iwconfig wlan0mon mode monitor
  • ifconfig wlan0mon up

In that way, you don't have to kill other conflicting programs, including network-manager.

1
  • I wouldn't also use airmon-ng at all, just use ifconfig/iwconfig to put your card into monitor mode.
    – Gewure
    Sep 27, 2017 at 17:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .