1

This question already has an answer here:

I work on a fresh Kali install running in a VM. I have an external Wi-Fi NIC used only by the VM (I try to not use the internet connection of the host).

The network is protected (hum) by WEP, with the following IP adresses :

  • 192.168.2.117: the target
  • 192.168.2.254: the gateway
  • 192.168.2.116: the attacking station

I've tried the following steps:

echo 1 >  /proc/sys/net/ipv4/ip_forward
arpspoof -i wlan0 -t 192.168.2.117 -r 192.168.2.254  # I also tried without the flag `r`
arpspoof -i wlan0 -t 192.168.2.254 192.168.2.117  # I also tried without this line

The ARP table of the target is modified, and on the attacking station I see all the requests from .117 (on Wireshark). But there is no response from the gateway; I even doubt than the attacking station forward the requests to the gateway. My iptables is totally empty and the policy is on ACCEPT everywhere.

So where I am wrong, and how enable the forwarding of the requets?

marked as duplicate by Matthew, Xander, Tobi Nary, Neil Smithline, LvB Apr 14 '16 at 9:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What is your real question? – M'vy Apr 13 '16 at 9:37
  • It was on the title. I've edited. – Shan-x Apr 13 '16 at 9:43
  • what version of arpspoof are you using ? – Emadeddin Apr 13 '16 at 9:44
  • The title is not very descriptive. Blocks internet for whom? – M'vy Apr 13 '16 at 9:44
  • @Emadeddin: arpspoof version 2.4 – Shan-x Apr 13 '16 at 9:47
0

Based on this question and its answer, you have to do the following:

  • remove iptables entries.
  • arpspoof -i wlan0 -t 192.168.2.117 -r 192.168.2.254
  • arpspoof -i wlan0 -t 192.168.2.254 192.168.2.117

notice the -r flag.

  • Didn't work. Same results. – Shan-x Apr 13 '16 at 11:53
  • Most of arpspoof reviews are saying that the tool ain't working correctly. Try some old versions like those in BackTrack, and try it for Ethernet, not on wireless, and at last, try to put your wireless on monitor mode. – Emadeddin Apr 13 '16 at 12:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.