1

I have two wireless adapters, one is internal PCI wireless adapter (wlan0) while other is USB wireless adapter (wlan1).
I put wlan0 in monitor mode and wlan1 is in managed mode. But, after running

ifconfig wlan0 down 
iwconfig wlan0 mode Monitor 
ifconfig wlan0 up
sudo airodump-ng wlan0       //???

wlan0 goes successfully in monitor mode but I lost internet connection. When I use

sudo service network-manager restart  

then wlan0 switched back to managed mode.
Is there any way to put wlan0 in monitor mode while keeping wlan1 in managed mode and not loosing WiFi connection?

2

You could do it all more "manually" :

Set your wlan0 interface down : ip link set wlan0 down.

Change the mode from managed to monitor : iw dev wlan0 set type monitor.

And bring back up : ip link set wlan0 up.

And you can check the result with a simple iw dev.

That shouldn't change anything on your other interface wlan1, at least it does it for me (Debian 8). I don't know why you lose connection when launching airmon-ng start but I never managed to use it correctly, hence these 3 commands above...

  • I tried this ifconfig wlan0 down iwconfig wlan0 mode Monitor ifconfig wlan0 up and it worked until I ran the command sudo airodump-ng mon0. Now Internet is gone. – haccks Apr 22 '16 at 12:06
  • You have two 'real' interfaces, wlan0 and wlan1. mon0 is created by airmon-ng in our case here. Your problem is quite strange and as I said, I never use airmon-ng as I always failed to do anything with it, finding myself left with a virtual interface mon0 and as well, losing my connection. I use my 3 commands I wrote above and then launch airodump-ng wlan0. Now, you say internet is gone, or maybe your wifi connection from wlan1 ? (ip a : any ip assigned to wlan1?) – Bamse Apr 22 '16 at 12:12
  • Yes, my WiFi is gone from wlan1. Before running airodump-ng wlan0 I wan connected with WiFI through wlan1. – haccks Apr 22 '16 at 12:20
  • Could you go through the whole process again ? Starting with only wlan0/1 (no mon0, remove it), to point out when exactly you lose the connection. I understand clearly what you want since I had the same problem (an interface for airodump and other for internet), and I only managed to do so with manually setting the monitor mode. Another thing that you could try : instead of running sudo service network-manager restart, you could always set up in managed mode wlan1, release whatever you have for dhcp : dhclient -r wlan1 and ask for an ip : dhclient wlan1, and leave your wlan0 alone! – Bamse Apr 22 '16 at 12:35
  • I edited the question and removed mon0. Now forget airmon. I loose connection when I run airodump-ng wlan0. wlan1 is in managed mode and was connected to WiFi before losing the connection. – haccks Apr 22 '16 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.