2

Why are there dash marks through the https portion of this address? Is this a feature that's supposed to further accentuate that this is unsecured https? I just thought it was a graphical glitch because I have never seen these kinds of dash marks through any other site that I have accessed over https whether the cert is self-signed or issued through a CA.

Strange dashes in Firefox address bar

Additionally, selecting the address in the address bar causes the dashes to go away for as long as the address is selected:

Hidden dashes when address is selected

I am using Firefox ESR 45.1.1 in case that matters.

4
  • 1
    To be honest, looks like a rendering glitch to me, but I don't feel like booting a Windows VM to check. Maybe try out some test bad certificates and see if you can reproduce?: badssl.com May 27, 2016 at 0:07
  • @AlexanderO'Mara Hmm, https://mixed-script.badssl.com/ reproduces it, as does https://very.badssl.com/ but many of the others do not, so it might only occur for mixed-content sites.
    – zero298
    May 27, 2016 at 0:10
  • Odd, you've convinced me to try it in a VM, but I can't reproduce it. Windows 7 Firefox ESR 45.1.1 (32 and 64 bit FF the same). Extension related maybe? May 27, 2016 at 0:17
  • Wait, my icon looks different from your new screenshot: i.sstatic.net/Yvgtx.png May 27, 2016 at 0:20

1 Answer 1

6

When the connection is insecure due to mixed content, and you've disabled mixed content blocking, the strike through is supposed to be solid line over the https scheme name:

img
(source: mozilla.net)

That yours show up as broken lines is probably a graphical glitch.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .