While I was visiting a page on a usual website with the built-in browser of the Android Facebook app, a pop-up just... poped-up, saying dumb stuff about my cellphone being full of viruses, etc. (Quite similar to "Virus Found" Web Browser Pop-up) Not wanting to click on anything, I just frenetically tapped the "back" button of my Android Cellphone, which prompted the pop-up to come back until eventually Google Play Store opened and offered me to install "https ://play .google. com/store/apps/details?id=com.duapps.cleaner"

Tapping the home button of my cellphone, then using the app switcher to close Facebook, everything seems to be fine again.

My question is: Is there some way to prevent this from happening again? I mean, I was visiting a (I think) perfectly legit website which I visited many time before. Also, this is the first time I see this on a phone's browser (maybe I was just lucky until now)

  • 3
    Likely malvertising. Probably can't be prevented unless you stop using the browser. Killing the app was the perfect thing to do May 31, 2016 at 2:07
  • 5
    Firefox on Android can use an ad blocker. That should help some. Just install Firefox from the store and then search plugins for adblocker May 31, 2016 at 2:09
  • I am facing the same problem with the Facebook app on iOS. Horrible pop-ups in the Facebook mobile browser when I followed the (xx-munged)-link: hxxps://www.jta.org/quick-reads/dozens-arrested-in-demonstrations-protesting-ethiopian-israelis-shooting-death-by-off-duty-cop Jan 3, 2020 at 20:37
  • or not using Facebook or not using the Facebook app Hmm... menu..settings&p..settings..browser..[dead end- only option is to clear all cookies and cache]. Any ideas? KNOWN WORKAROUNDS: taking the extra step of clicking […]… “Open Safari” again and again and again and again..., or not using Facebook or not using the Facebook app! 👈🗣 Jan 3, 2020 at 20:43

1 Answer 1


Yes, the answer is simple. Go to the Facebook App's settings page and turn on "open with external browser" or somesuch, and the infernal internal browser in the FB app will be silenced!

  • 2
    I tried to find this setting and cannot. Can you confirm the steps to change this setting? And can you confirm that you are talking about the mobile Facebook app and not a Facebook app from within Facebook?
    – schroeder
    Oct 19, 2017 at 7:17
  • 1
    Step to this options: Hamburger Menu -> App-Settings -> open Links external to true
    – Serverfrog
    Oct 19, 2017 at 8:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .