I just authorized remote access to my Windows 7 machine (not using NLA, since I run a mainly Linux network). I diabled Remote Assistance.

My user (JoeBlow) is protected with password 123456 and autologon is not enabled.

When I connect from a Linux (Ubuntu) box, with a local user named JoeBlow, using password 0987654 (or anything else, it doesn't matter) through KRDC, it logs me directly in JoeBlow's windows session, without prompting for a password.

Did I miss something on the Windows setup side, or is RDP built in such a way as to allow anyone impersonating a user on a network to hijack the session?

  • DomLen, welcome to Information Security. I recommend registering your account, to take full advantage of the site's features, such as tracking your posts, accruing reputation, and more - see the FAQ for more details.
    – AviD
    Mar 18, 2012 at 2:06
  • Your question sounds intriguing - could your RDP client have saved the real password in a previous session?
    – AviD
    Mar 18, 2012 at 2:06
  • Interesting. Have you created a home group with Windows 7? Mar 18, 2012 at 5:13
  • @AviD: I've created the connection and it connected automatically. Therefore, I doubt that it saved it in previous sessions, unless KRDC saved e.g. the MAC address...
    – DomLen
    Mar 18, 2012 at 12:51
  • @Bernie White: Yes, I created a home group. I changed it to a work group, and it still logs me in the user screen.
    – DomLen
    Mar 18, 2012 at 12:51

2 Answers 2


It's not normal behavior for it to just log you in by username.

My best guess is that you have the password saved either in the RDP program or your gnome keyring or something like that.

An easy way to test would be to change the password on the windows machine and see if it starts prompting you for a password again.


I'm not 100% positive on this but I would re-think the way you want to access and use a more secure password (not that the complexity matters if you have physical access to crack the SAM file). I would look into teamviewer or logmein, both offer free solutions for remoting in. Also both teamviewer and logmein have android apps to remote in from your phone or tablet. Personally I like logmein, it has decent logging and reporting features even on the free accounts (I have it installed on over 150+ machines, you just don't have the ability to transfer files with the free version) If these ideas won't work for your application let me know in more specifics what and how you want to design the infrastructure.

I'm sorry that my above answer was displeasing to some I was only wanting to offer a known alternative solution without having to reload the operating system.

I've converted a test box to try this out for myself.

under, start/windows button, right click computer and then left click properties. This will open up your system properties or press the windows key + Pause/Break will get you there as well. on the left click "Advanced System Properties". Under the remote tab you have 3 options:

  1. Don't Allow Connections to this computer
  2. Allow Connections from computers running ANY version of Remote Desktop (less secure)
  3. Allow Connections from computers running Remote Desktop with Network Level Authentication (more secure)

I'm assuming that the second option might be selected. I would reccomend the third option and define the account that will have access and all other credentials would be denied.

Both options 2 and 3 work on my win 7 test box without any issues. Have you ran system file checker to see if there is a corrupted file screwing things up? To do this run a command prompt as administrator and run "sfc /scannow" without the quotes. If you need more info on the system file checker check out: http://support.microsoft.com/kb/929833

Another item to consider is that when RDP is running you lock the machine of the local user and run your own session. I don't know if this is an issue for you or not.

One other thing to look into is if group policy get set to allow any access with or without passwords by running gpedit.msc and browse to Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Accounts and take a look at how things are configured.

  • 1
    This question is specific to RDP and it behaviour experienced by DomLen. This does not answer the question. Mar 20, 2012 at 20:52
  • If none fo my troubleshooting worked then rebuild the system from scratch. The issue is that RDP or it's configuration are corrupted somehow, I don't see how troubleshooting the issue doesn't qualify as an answer.
    – Brad
    Jul 10, 2012 at 18:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .