0

The situation is pretty simple, I'm trying to create a rogue AP, am I missing something? No matter what I do I get the same error message:

Unable to create tap interface using airbase-ng

I tried using different bssid and essid's with the corresponding names and channels.

Killed the processes, downed the interface, up again.

I deleted wlan0mon, disconnected the antenna from vm, then physically, reconnected everything, made some tests with different tools, airebase-ng still not working.

No problem with aircrack, airmon, airodump, aireplay, they all work.

If it's of any help I am using an Alfa AWUS036H 802.11 b/g wireless USB adapter iwconfig: Wireless card is configured in monitor mode

And the correct drivers are installed: output from dmesg

The worst thing is there is not indication of error in the command syntax or a parameter missing.

1

Can you post an image without blurring information... Maybe you're just adding a blank space on the ESSID and jumping a command, add quotes on strings, like this:

airbase-ng -c 11 -a AA:AA:AA:AA:AA:AA --essid 'I use blanks on my essid' wlan0mon

Try this to test:

airbase-ng -c 2 --essid test -a AA:AA:AA:AA:AA:AA wlan0mon

or without the -a (Use your default MAC)

airbase-ng -c 2 --essid test wlan0mon
0

If you want create rogue AP, with a lot of things automated do check WiFi Pumpkin a good framework for it.

WIFI Pumpkin

0

Hard to tell with the deprecated details, however if there spaces in the ESSID then try adding quotes around the name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.