0

When testing a HTTPS URL it loads successfully from all browsers on mulitple desktop operating system. However when we test specifically from Android mobile phone we get the following results:

Android using Dolphin browser:

Security warning

The name of the site does not match the name on the certificate. Do you want to continue? (Cancel / Continue)

enter image description here

Android using Chrome:

It displays the message:

No Certificates found

Chrome has requested a certificate. Agreeing to this request will allow the application to use this certificate with servers from now on. The requesting server has been recognized as :443. Only agree to this request if you trust the application.

You can install certificates from a PKCS#12 file with a .pfx or .p12 file extension.

With "Install" or "Cancel" buttons at the bottom of the error message dialog.

enter image description here

The really interesting thing is when testing on the same Android phone using Firefox and UCbrowser the URL loads successfully without these error messages.

When loading the same URL using an iPhone with either Chrome or Safari both also load successfully.

Would anyone have any pointers on what we should check regarding the setup?

Regards, Leigh.

  • if its hosted on iis this might help u stackoverflow.com/questions/11745835/… – BlueBerry - Vignesh4303 Aug 2 '16 at 11:53
  • It is very likely it is issue with recent switchover (2016) from SHA-1 to SHA-2. Your server might need to have loaded additional certificates so the whole chain can be validated by your android client. It is called "Intermediate Certificate". For example, "G3 Intermediate". See this: digicert.com/transitioning-to-sha-2.htm along with any additional intermediate certificates they require. The thing that "hostname does not match" might be misleading at first in your case. It is the thing that it just wont validate well. – Aria Aug 2 '16 at 13:46
  • Thanks Aria, I've now logged a support ticket with our SSL certificate provider, Thawte to check our setup. – shwashbuckle Aug 2 '16 at 14:09
  • 1
    I've found this to be helpful in troubleshooting SSL/TLS: ssllabs.com/ssltest – Jesse K Aug 2 '16 at 14:21
  • The following article stackoverflow.com/questions/19992040/… explains the same problem we are getting. Still need to look at the setting SSLVerifyClient="none" on our server... – shwashbuckle Aug 2 '16 at 22:23
0

We managed to solve this issue. Our webserver is Tomcat and the fix was to follow the steps below:

  1. Backup \repository\conf\tomcat\catalina-server.xml
  2. Shutdown the Tomcat Server
  3. Modify the catalina-server.xml file by changing the setting clientAuth=want to clientAuth=false
  4. Start the Tomcat Server.
  5. Ensure the Tomcat server is started correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.