1

There is a website with no HTTPS certificate on it and i have checked it is transmitting username password in clear text.

I scanned the system and application using IBM Appscan and Nexpose

IBM Appscan (Web Vulnerability Scanner) detects no HTTPS which i can confirm by opening link on browser

Nepose (Vulnerability Scanning tool) detected that self signed certificate is implemented on port 443 it tried to open webpage with port https://url:443 but page redirects to normal http (no certificate) nexpose also detects TLS 1.0 is implemented

Application vendor says that on back end TLS is implemented

How can i verify that TLS is implemented on back end ? Nexpose confimred it but is there any other way

  • And what is this question about? You stated it is transmitting plain text. Then? – techraf Aug 5 '16 at 6:45
  • do you get https as SERVICE in nmap -sS -Pn -p443 youserver ? – elsadek Aug 5 '16 at 6:49
  • which server is used ? did you get redirected when you visit weburl:443? – elsadek Aug 5 '16 at 6:53
  • Hi Guys, i just tried full link it is now opened in HTTPS with certificate thus it means site support both https and http ? nmap result Port 443 State Filterd Service HTTPS System is UP – Ishaq Paracha Aug 5 '16 at 7:01
2

Use OpenSSL to attempt to connect and dump the certificate (if any).

openssl s_client -connect <server>:<port>

If it fails to connect, TLS isn't implemented. If it connects, then you'll get the certificate and you can check what it looks like.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.