-1

This is my question: How to connect reverse_tcp meterpreter with my remote server(NOT in the same machine where i have installed metasploit)? It's possible? I need this because i haven't a public ip address which can be accessed from internet in my home.

  • Please explain your question further, try to tell us what steps you're trying to make exactly. thanks – Emadeddin Aug 8 '16 at 9:32
  • Hi friend. I kali installed in my pc. I want to run an exploit to a target that is outside of my local area network (so it's only accessible via internet). By using the reverse_tcp payload should I configure LHOST parameter. The problem is that I do not have a public ip address, so my PC is not reachable from the internet. So I want to use a remote server, which I have already, as LHOST. At this remote server I can only access it via ssh, I can not physically. – dalvik Aug 8 '16 at 10:23
0

First, you are wrong about that the target can't reach you if you're on a local network. You just need to enable port forwarding on your router.

And as for your question, the answer is YES, just provide the payload with your server's IP and listener port. As long as you have an ssh connection to your server, that means you can get cmd screen and get all open sessions, including your meterpreter session with the target.

But you'll need the followings:

  • Start meterpreter listener on your server 'or at least a generic tcp listener'.
  • Implement some way to get notified by a new connection.

I recommend to automate all your hacking procedure, i.e:

  1. Create your own payload, that enables the victim to start specific scripts on server.
  2. Use a script to migrate your meterpreter session.
  3. Use some generic hacks scripts. 'For example: mirroring all documents.

If you need further explanation, please modify your question.

  • "First, you are wrong about that the target can not reach you if you're on a local network. You just need to enable port forwarding on your router." is not a question of portforwarding, I do not own a public ip because my ISP does not provide them. – dalvik Aug 8 '16 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.