1

I was trying penetration testing on my wifi and every time when I use command aireplay-ng -1 0 -a bssid wlan0mon and hit ENTER the response is Waiting for beacon frame bssid on channel 11. wlan0mon is on channel 11 but the AP uses channel 1.

How can I solve this problem? I am currently new to this. I tried something like sudo iwconfig wlan0mon channel 1 but it didn't work.

  • 1
    You should be using the -c or --channel argument, check the docs for full info – Paradoxis Aug 16 '16 at 8:56
  • just try to stop and restart the command, as the wifi card is set to auto, it will change the channel to another one, and you'll get the correct one eventually. Or you can set the wifi card to work on a static channel from beginning. – Emadeddin Aug 16 '16 at 10:44
1

If you know the channel you want to attack, then when setting your network interface in monitor mode, just specify it:

airmon-ng start wlan0 1

Also, I notice you use -1 0. Don't forget that this "attack" mode does not work with WPA/WPA2.

Hope this may help you :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.