2

I am trying to install inetsim on Ubuntu 14.04 where I have been following instructions from several blogs and the inetsim.org documentation itself at: inetsim download and installation

Now one of the blogs mentions the way to install several of the dependencies of inetsim.

Everything from the above blog works fine, except for the part where you are supposed to install a dependency called Perlipq.

When i try to make perlipq as suggested in the blog above, i get an error that says

IPQueue.xs:11:20: fatal error: libipq.h: No such file or directory

some further research suggested that Makefile was trying to locate libipq.h in /usr/local/include as suggested by line number 155 in my Makefile as :

INC = -I/usr/local/include

I checked the location and figured out that the libipq.h header file is not present at that location. Nor does locate/find for libipq.h returns any results.

Through some further digging in I came across the change logs of IPTABLES and figured out that libipq.h references have been removed from IPTABLES beyond a certain version. In my case :

iptables --version is iptables v1.4.21

which falls in the above category.

Now one way to fix this could be to remove the iptables I have and install an older version that still supports libipq.h, but am afraid doing so might break the other stuff that might be dependent on the latest versions of iptables.

Is there some other way to get inetsim working on my Ubuntu 14.04? Or do I have to take the approach of installing an older iptables itself ?

  • Although the problem is not solved, but guess the perlipq dependency is an optional one. So, inetsim would still work fine even without installing this dependency, as long as none of the functionality of the above package is requested. – qre0ct Aug 17 '16 at 10:37
1

Kali Linux has inbuilt inetsim you can try that..! or else check it out https://techanarchy.net/2013/08/installing-and-configuring-inetsim/ it has step by step process

  • 1
    thanks for the advice. However, I have a specific requirement wherein I need to explicitly use Ubunut trusty and the blog you mentioned about is an outdated one dating back to 2013. So although I haven't tried the suggestions from this blog, I have tried similar things ( a lot ) from other blogs and most of them are broken as far as it's the libipq concern mentioned in my question. – qre0ct Aug 17 '16 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.