2

I tried the aireplay test but it said "No Answers" instead of "Injection is working". I also get error of List of possible errors (which also includes packet injection problem) when trying to associate with aireplay. But my adapter is in monitor mode.

aireplay-ng --test wlan1mon

gives

Trying broadcast probe requests...
No Answers...
Found 0 APs

My chipset is a Ralink Technology, Corp. RT2870/RT3070

I'm kind of a beginner in this so go a little easy on me. Thanks in advance.

SOLVED:

The test result says "No Answers..." and "Found 0 APs". There was no AP nearby that can give answer to ensure that your adapter actually supports packet injection, so of course there's no answer from any AP.

Make sure you are close enough to the AP (any WiFi hotspot). If that didn't work, Go to aircrack's official site to check whether your adapter is capable or not.

6
  • 7
    buy a new adapter that supports packet injection!
    – Eibo
    Commented Sep 5, 2016 at 6:58
  • Take a look at security.stackexchange.com/questions/135837/… It is not exactly the same, but looks related Commented Sep 5, 2016 at 6:59
  • No, that's not the issue. tried it. see edited question for the error
    – Slim Shady
    Commented Sep 5, 2016 at 7:34
  • Are you close enough to the AP, have you tried another card, maybe it's an OS problem. What is your OS version?
    – Eibo
    Commented Sep 5, 2016 at 7:42
  • many blogs referred to it as an OS problem, you need to install kernel headers and other required files, try to use another OS with another version.
    – Eibo
    Commented Sep 5, 2016 at 7:52

2 Answers 2

2

Have you read the aircrack article about supported cards? Start there to begin with. They even have a tool to test if your cards supports monitor/injection mode. If the hardware doesn't support modes other than station infrastructure mode, you're out of luck. If it does, then make sure you have the correct drivers supporting this feature. At last you OS should have the tools to inject/monitor, but this is not the problem, most of the time.

From what I have found (just by searching, I haven't actually confirmed anything) is your card doesn't support injection or monitor mode.

2
  • Thanks, but actually the problem this whole time was I wasn't close enough to the AP. see my comment above
    – Slim Shady
    Commented Sep 5, 2016 at 8:18
  • 2
    @BenJunior Next time, RTFM and there would have been no need to post this question. Commented Sep 5, 2016 at 8:28
1

Had the same issue but I realized my device was under monitor mode and needed to be under managed mode, here are the steps for both:

Setting up the card in monitor mode

#Set interface down
sudo ip link set wlan0 down
#Set monitor mode
sudo iwconfig wlan0 mode monitor
#Set interface up
sudo ip link set wlan0 up
Verifying monitor mode
sudo iwconfig

Testing card by sniffing nearby networks

sudo airodump-ng wlan0

Changing the adapter back to manage mode

#Set interface down
sudo ip link set wlan0 down
#Set monitor mode
sudo iwconfig wlan0 mode managed
#Set interface up
sudo ip link set wlan0 up
#Try again... 
sudo aireplay-ng --test wlan0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .