4

I work at coffee shops a lot and signed up for Mullvad VPN to be more secure (after reading many reviews). The service works fine at home but rarely works on public Wi-Fi, whether from a chain like Starbucks or at a public library. Is it common for these places to block VPNS or is there something else I need to do before connecting to mine?

6

Mullvad is an openvpn implementation, which (therefore) should be capable of using either IPSec (over UDP) or TLS (over TCP). Some customer grade routers have problems with IPSec but, more likely, a coffe shop simply allows ports 80 and 443 through the firewall and noting else. The default OpenVPN port is 1194 which may be blocked by a restrictive firewall.

I strongly believe that Mullvad will allow you to use port 443 to connect to their servers. The following is an excerpt from my old Mullvad openvpn.conf. It may be outdated since I do not use it in more than two years, but I do not believe that they changed the policy:

# Notice to Mullvad customers:
#
# Apart from openvpn, you also need to install the
# package "resolvconf", available via apt, e.g.
#
# For those of you behind very restrictive firewalls,
# you can use our tunnels on tcp port 443, as well as
# on udp port 53.

Therefore:

  1. Configure the VPN to use TLS (--tls-client/proto tcp-client)
  2. Use port 443 (remote openvpn.mullvad.net 443)

And you should be able to avoid (most) issues with IPSec incompatibility and restrictive firewalls.

1

I had this problem in Mullvad and solved it in the client by going to Settings > Advanced and changing the protocol to TCP. That changes the port automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.