0

I am unable to install Kali 2016.2 using a USB. The installation demands a CD-ROM. This cannot be right... Right?

EDIT: Kali Linux 64 bit (25cc6d53a8bd8886fcb468eb4fbb4cdfac895c65) ISO used together with Universal-USB-Installer-1.9.6.4

I am using a separate SSD installed in a DVD-drive caddy, and I would like to install Kali on this drive. This is because I want to continue to have the option to use Windows on this laptop, but I do not want to lose space by creating a partition. So I do not have a free CD-ROM drive to install with unless I take out the primary internal drive and this seems like a lot of faffing about to do at 5am when a USB boot would be so much more convenient.

I boot from the USB and choose the option to perform a graphical installation. However, less than a minute into the installation process, I am told I need a CDROM to continue installation. No CDROM is found since it is a caddy, and so I have to abort the installation.

Is there any way to work around this so that I can have a separate caddy SSD with Kali?

UPDATE: I have tried running the installation from the USB as a non graphical install; I get the same error. It reads:

'Your installation CD-ROM couldn't be mounted. This probably means the CD-ROM was not in the drive. If so you can insert it and try again.'

Insert CD-ROM error

Surely I should be able to easily install from a USB in 2016 - half of notebooks these days do not even have CD drives. What am I doing wrong??

closed as off-topic by techraf, Steffen Ullrich, schroeder Oct 9 '16 at 7:39

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Information security within the scope defined in the help center." – schroeder
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Ehkm... this does not really has anything to do with information security (and is therefore off-topic here). Moreover, you managed to write some 300 words about your USB drive problems without telling how did you create it or which image you downloaded (there is more than one image of Kali 2016.2). Once you add that info your question is adequate to unix.SE. – grochmal Oct 9 '16 at 3:29
  • Yes, I noticed that just after I wrote it (the off topic part). Thought this was a Kali forum and started writing too quickly before I realized. Will add the information you suggested but will understand if the whole question is closed as off topic. – Matthew Oct 9 '16 at 3:32
  • @grochmal Transferring question to unix.SE but cannot delete it. Grateful for advice. – Matthew Oct 9 '16 at 3:39
  • Please wait for the community to migrate posts, and don't duplicate. – schroeder Oct 9 '16 at 7:38
  • @schroeder I will do so in future. – Matthew Oct 12 '16 at 18:23
1

For me, I flashed the full kali image to a large flash drive, then booted. I would recommend doing the same. Also, make sure that you are not using the VM version

  • Ok, will try that now. How did you flash it exactly? All I am able to get is the installer... – Matthew Oct 9 '16 at 3:17
  • I did this on a mac, so it may be a bit different for you – dGRAMOP Oct 9 '16 at 3:19
  • Ah, yes I am on a Toshiba Satellite – Matthew Oct 9 '16 at 3:20
  • Try using the "Kali Linux 64 bit Mate" image – dGRAMOP Oct 9 '16 at 3:20
  • The process should be the same, there may be only a couple of minor differences – dGRAMOP Oct 9 '16 at 3:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.