1

I have tried all ways to resolve an issue I have at one of the office sites I look after.The problem is that a deployment rules set was signed previously with a certificate that has now expired so I need to re-create the java deployment ruleset and sign with certificate. I used the following commands to create the ruleset and sign:

jar -cvf DeploymentRuleSet.jar ruleset.xml

keytool.exe -genkey -alias SelfSigned -keystore "SelfSigned.jks" -keyalg RSA -keysize 2048 -startdate "2016/11/01 00:00:00" -validity 18262

Answering the prompts, type “yes” to trust the cert and use the same password as the keystore password.

keytool.exe -export -file "SelfSigned.cer" -alias SelfSigned -keystore "SelfSigned.jks"

jarsigner.exe -keystore "SelfSigned.jks" -signedjar "DeploymentRuleSet.jar" DeploymentRuleSet.jar SelfSigned

jarsigner -keystore "SelfSigned.jks" -tsa http://timestamp.comodoca.com DeploymentRuleSet.jar SelfSigned

Unfortunately I still get the error message the following:

Timestamp: Timestamp not available

DeploymentRuleSet.jar is invalid: Cannot verify self-signed Deployment Rule Set jar.

I'm not a Java coder, I picked up the commands from other internet sources as no-one in our organisation seems to know how to do this and I don't want to pay a third party if I can do it myself.

Thanking you in anticipation of your help.

Andrew

  • Additionally I have a CA Code Signing Certificate but don't know the correct commands to create a deployment ruleset using it. – Gadget1st Nov 21 '16 at 14:24
  • Update: I have replaced second command with: keytool.exe -export -file "CodeSignCertificate.cer" -alias SelfSigned-keystore "SelfSigned.jks" Result is that there is now a timestamp but still cannot verify ruleset jar – Gadget1st Nov 21 '16 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.