How can I run hashcat using only the cpu in a virtual machine?

When I try to run hashcat in my Kali 2 VM I receive the following error:

root@kali: hashcat -m 400 -a 0 hash.txt rockyou.txt
hashcat (v3.10) starting...

OpenCL Platform #1: Mesa, skipped! No OpenCL compatible devices found

ERROR: No devices found/left

I realize the newer version of hashcat wants to access a video card. This is a Virtual Machine and I'd prefer to use the CPU for these labs.

Version info for Kali:

root@kali:~/Desktop/data/target# uname -a
Linux kali 4.6.0-kali1-686 #1 SMP Debian 4.6.4-1kali1 (2016-07-21) i686 GNU/Linux

root@kali:~/Desktop/data/target# lsb_release -a
No LSB modules are available.
Distributor ID: Kali
Description:    Kali GNU/Linux Rolling
Release:    kali-rolling
Codename:   kali-rolling

You must install some stuff. The same happened to me. But you can work with new hashcat 3.x and CPU in your vm, no problem on that:

apt-get install libhwloc-dev ocl-icd-dev ocl-icd-opencl-dev


apt-get install pocl-opencl-icd

This worked for me. I found it here. What I suggested It's a little different because you can install pocl with apt-get instead of downloading from git like that link suggests... Is the solution worked on my Kali vm.

| improve this answer | |
  • 2
    Awesome! After an apt-get upgrade on 64 bit kali and using the --force flag, this worked like a champ! It won't run on 32 bit Kali without a lot of massaging apparently, but at least I have a viable option! This article discusses running hashcat in a 32 bit vm but it seemed a bit involved... – Shrout1 Jan 5 '17 at 21:16

You can use hashcat legacy for that, it's built to run on CPUs rather than GPUs.


| improve this answer | |

VM has no GPU, therefore hashcat can't work in it. You can either install legacy hashcat as knipp suggested, run it in your host machine or use Kali as a live OS (f.e. USB)

| improve this answer | |
  • He is asking to work in vm wih CPU and that is possible without any problem. – OscarAkaElvis Jan 5 '17 at 20:31

Try hashcat -m 400 -a 0 hash.txt rockyou.txt --force.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.