0

Im using Aircrack-ng suite to apply an evil-twin attack with my RaspberryPi3 operated by Kali-linux on another RspberryPi3 with Raspbian Jessie.

The steps are as followed:

1.configuring the apache2 server details at /etc/apache2/mods-available/userdir.conf

2.configuring the isc-dhcp-server at /etc/dhcp/dhcpd.conf

my dhcpd.conf file:
authoritative; default-lease-time 600; max-lease-time 7200; subnet 192.168.2.0 netmask 255.255.255.0 { option subnet-mask 255.255.255.0; option broadcast-address 192.168.2.255; option routers 192.168.2.1; option domain-name-servers 8.8.8.8; range 192.168.2.1 192.168.2.20; }

3.I have changed the NetworkManager.conf file so monitor mode wont interfer with the manager as follows:

[main] plugins=ifupdown,keyfile [ifupdown] managed=false [keyfile] unmanaged-devices=interface-name:wlan0mon;interface-name:wlan1mon;

4.running:
airmon-ng start wlan1 airodump-ng wlan1mon
after choosing AP to duplicate : Dbest on ch#4 , running: airbase-ng -e "Dbest" -c 4 wlan1mon

At this point, im suppose to see "Dbest" broadcasting its ESSID to all of my wireless devices, although I only see the fake "Dbest" AP on the same device I have created it with(my kali-linux), as shown: Kali-linux wifi situation

And on my Raspbian jessie I only see the original"Dbest" I am connected to and the fake one doesnt even appear, as shown:
Raspbian Jessie situation

After a quick check with iwlist wlan0 scan on the Jessie, the interface can "see" a network called "Dbest" and according to dhcpdcd panel addon "wireless and wired connections" The Pi can actually see the fake AP but I cant authenticate to it: raspberry Jessie dhcpdc

I have allocated IP and subnet Mask to the at0 interface created by airbase-ng, I have also enabled NAT routing options, dhcp listener, and the apache2 for the fake authentication though this has nothing to do with the problem.

Any ideas on how to make my fake AP visible?

both RaspberryPi3's has BroadCom BCM43430 wireless Chipset (wlan0) My kali linux has USB input wifi adapter Atheros AR9271 wireless chipset (wlan1) Everything is up-to-date, firmwares of the chipsets, drivers and my raspberrys are updated and upgraded.

1

You see two of the same SSID because they have different settings, to merge them and create an evil twin you need to meet some conditions, you need to have the same settings in both AP.

  • ESSID (What probe requests look for)
  • Encryption algorithm (Open, WEP, WPA, etc.)
  • Cipher (CCMP, TKIP, WEP40, etc.)

This is called WiFi roaming

Here's another question asking ALMOST the same:

Try adding the option -z or -Z to airbase

  • 1
    Thanks for the reply but I have just installed Kali-Linux on both my machines since Kali as no problem supporting WEP,WPA etc... , and now I do see the ESSID I want – eyal360 Jan 19 '17 at 7:21
-1

For people searching for the exact problem I had, I installed a "better" software than Raspbien Jessie, since Raspbien doesn't support any wifi encryption that isn't WPA,WPA2..

I installed Kali on my machine using an image from their official site and now I see everything. https://www.kali.org/downloads/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.