2

I'm trying to capture data from my iOS device (specifically a troublesome app) and when I configure it to use my laptop on the same wifi as a proxy, I lose all connectivity.

Here's what I did in Burp Suite Free (v1.7.16):

  • Turn off intercept (So the button reads Intercept is off)
  • Under Options, disabled Run on the loopback listener.
  • Added a new listener: All interfaces, port 8080. I left the remaining options defaulted.

On iOS:

  • Added my laptop's IP address as the host, and port 8080 as the port.

It seems like no traffic at all is getting through, whether SSL or not.

Quick edit : The firewall is disabled on my laptop.

closed as off-topic by schroeder Apr 24 '18 at 20:24

  • This question does not appear to be about Information security within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    are you sure you have connection between both machines? can you ping between them? which browser are you using? safari? firefox? I guess your browsers config is ok setting correctly proxy ip, port, etc... – OscarAkaElvis Jan 27 '17 at 18:15
  • @OscarAkaElvis - Looks like I might've just put the cart before the horse. Can't ping from iOS to laptop (using a "ping" app), nor from laptop to iOS. The router here might be doing a VLAN, though on the same subnet. I'll try again from a different router soon. Thanks! – The1nk Jan 27 '17 at 18:42
  • 1
    Yeah some times wireless APs have "clients isolation" activated. – OscarAkaElvis Jan 27 '17 at 18:44
  • I'm voting to close this question as off-topic because it looks to be a basic networking problem not a security issue. – schroeder Apr 24 '18 at 20:24
0

Set Burp proxy (you can leave the loopback alone for other tasks) all interfaces to a port like 8082. Set your iOS device internet options to proxy to your Burp proxy IP/port. Don't forget to install Burp's certificate on your iDevice for SSL. It'd be the same for Android or any other device.

0

You could try setting up wireless hotspot on your laptop and connecting to that. I had issues a few years ago that I never properly resolved trying to connect an android app to my laptop running as the server. Worked fine as a hotspot, couldn't sort it on the wifi. I think it was some firewall setting somewhere but I never got to the bottom of it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.