1

SSL_ERROR_NO_CYPHER_OVERLAP

I'm getting this error message each time I try to open wikipedia.org from my laptop since a week now. First I thought it was due to VPN connection, but even when it's closed I also get this message.

Few hours ago I opened it using my phone -in the same LAN with my laptop- and it worked, but still not working and getting the same message from different browsers.

Am I hacked? and what can I do to solve this problem?!!

EDIT: I'm using windows 10, and my phone is android 6m and both chrome and firefox are up-to-date. Another issue is I just tried to open it from a linux VM I'm using, and i got the same message too !! :(

  • Which OS are you on? Which versions of which browsers are you using? – Mike Ounsworth Jan 31 '17 at 16:20
  • For me, www.wikipedia.org and my browser agree to use the cipher suite (ECDHE_ECDSA with X25519), and (CHACHA20_POLY1305). Both of which are fairly new. My guess is that you're using an older browser / OS that doesn't know about the new crypto. – Mike Ounsworth Jan 31 '17 at 16:22
  • 2
    Can you use Nmap on any of those systems? nmap --script ssl-enum-ciphers www.wikipedia.org -p443 ought to show all the ciphers that are being allowed. We can compare to what others are seeing to know if something is interfering with you specifically. – bonsaiviking Jan 31 '17 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.