2

Today I encountered odd proxy settings on a user's Windows 10 installation.

Microsoft Edge had the proxy set to:

use proxyserver

The address field was set to:

...os=127.0.0.1:51144

The "port" field was empty.

The "no proxy for" field was set to:

<-loopback>

I was not able to change the proxy settings.

Is this a trojan of some kind?

5
  • I took a photo, but the fool I was I don't know what was in front of the "os=127.0.0.1:51144" Feb 10, 2017 at 15:04
  • Possible. Check what is listening on :51144 .
    – peterh
    Feb 10, 2017 at 15:37
  • You can do @peterh's check as follows: in an admin command prompt, run netstat -a -b to find out what ports are open and by what processes.
    – Ben Voigt
    Feb 10, 2017 at 16:06
  • This may be some sort of antivirus that tries to scan web traffic. Feb 11, 2017 at 1:03
  • Have yoy conected to any kind of WiFi network or VPN? It could be a proxy auto-config file. Jun 22, 2017 at 7:50

1 Answer 1

-1
  1. Click on the start icon.
  2. Click settings.
  3. Select Network & Internet.
  4. Select Ethernet on the left panel, and click Internet options.
  5. When the Internet Properties window opens, click the Connections tab.
  6. At the bottom of this window, click LAN settings.
  7. In the Local Area Network (LAN) Settings window, make sure the Use automatic configuration script and Use a proxy server for your LAN boxes are not checked, and then click OK.
  8. If any settings were changed, click Apply and then OK.
  9. Confirm the connection by testing two separate web pages.

enter image description here

1
  • This doesn’t really answer the question. Jun 22, 2017 at 7:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .