1

I have the following issue: Chrome browser (both desktop and mobile) shows me "Not Secure" label for my main domain "https://astrakhan.ru/" while it works OK for "https://www.astrakhan.ru/".

Firefox and IE work just fine. SSLabs also doesn't see any problem here -- www.ssllabs.com/ssltest/analyze.html?d=astrakhan.ru&hideResults=on (results are the same for both astrakhan.ru and www.astrakhan.ru).

What causes the problem? Chrome shows me only "net::ERR_UNEXPECTED" error but this doesn't seem to be any helpful.

  • Works for me with Chrome, i.e. your problem cannot be reproduced. Have your tried to restart the browser, reboot the computer, try Chrome from a different system etc? – Steffen Ullrich Feb 22 '17 at 11:11
  • Well, the problem is that we can reproduce this problem on a different PCs/laptops/smartphones and in different locations (Russia, Europe). Me and my colleagues use Chrome on Android, Windows XP, Windows 7, Windows 10. – Greg Feb 22 '17 at 12:02
  • Anyway, let's imagine that the only users who can reproduce this problem are the ones who visited this site before. Then how can I solve this problem? I tried to clear the cache and cookies with no luck. I'm also curious what will website visitors do in this case because this website has many returning visitors. – Greg Feb 22 '17 at 12:25
  • A packet capture from a failed connection could be helpful to debug the problem. You could upload it to cloudshark.org. – Steffen Ullrich Feb 22 '17 at 13:12
  • I assumed that if Firefox and IE don't see any problems with the mentioned website, then packet capture won't show anything unusual here. Seems to be a Chrome issue. I already sent a bug report. – Greg Feb 23 '17 at 0:02
1

I would suggest an easy alternative to test it out by just redirecting all the traffic for non-www urls to the equivalent www urls using the server configuration.

Here is an example for the nginx server.

https://serverfault.com/questions/624848/redirect-non-www-to-www-over-ssl-with-nginx

or have a look at this solution

https://serverfault.com/questions/738883/ssl-certificate-non-www-not-working

Hope it helps

  • 1
    This is not an answer which solves or explains the problem but just a tip how to debug the problem. It should be a comment instead. – Steffen Ullrich Feb 22 '17 at 11:12
  • @Maniac, I know that it's an option but main domain has much more trust in Google unlike "www" subdomain so I don't want to go this way. – Greg Feb 22 '17 at 12:03
0

It is a Chrome's bug: https://bugs.chromium.org/p/chromium/issues/detail?id=695193

Chrome still has an outdated version of public suffix list. On the one hand, it will be fixed in Chrome 57. On the other hand, this domain will be broken for any Chrome below 57th version forever. Thanks to Chrome's dev! :-(

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.