4

I've been messing with Hydra (Brute Force) to solve the "Damn Vulnerable Web App" brute force section but the problem is when I use http-get-form it said:

Warning: child 1 seems to have died, restarting (this only happens if a module is bad)

And the brute force command is:

hydra 192.168.100.15 http-get-form \
      "/dvwa/vulnerabilities/brute/#:username=^USER^&password=^PASS^&Login=Login:Username and/or password incorrect" \
      -l admin -P /root/Desktop/wordlists/test.txt -w 30

I can't find out why the module is bad.

2
  • have you tried dropping the "#" from your URL? DVWA doesn't need it.
    – schroeder
    May 24, 2012 at 1:15
  • Yes I did and replaced it with "index.php" but still the same issue
    – AmA
    May 24, 2012 at 10:09

1 Answer 1

5
hydra -l admin -P /root/Desktop/wordlists/test.txt dvwa http-get-form "/dvwa/vulnerabilities/brute/index.php:username=^USER^&password=^PASS^&Login=Login:Username and/or password incorrect."
3
  • that targets a different page on the dvwa site
    – schroeder
    Jun 1, 2012 at 4:08
  • Yes I did and it's working fine but I wanna know how can you do this command to sub directory such as: /dvwa/vulnerabilities/brute
    – AmA
    Jun 3, 2012 at 14:58
  • @AmA I have edited my answer, have you tried it?
    – pl1nk
    Jun 4, 2012 at 0:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .