1

I use the intruder extension xssValidator in burp suite pro to test for XSS vulnerabilities.

My problem is that when I set my payloads list in the xssValidator tab, just the first 32 lines will be included in the attack. If my fuzzing list contains 80 payloads, then just 32 will be taken into consideration and 48 payloads will be ignored.

how can I get it to use 80 payloads ?

  • What is your question? – Sjoerd Apr 17 '17 at 15:44
  • I feel like this is an XY Problem. Maybe you should take a step back and explain what you're trying to accomplish and why you need more than 32 lines. My guess is that you're trying to use the tool in a way that it was not designed for. – Mike Ounsworth Apr 17 '17 at 15:46
  • xssValidator is a burp extension available in the BApp Store, it can test for XSS vulnerablities in webapps and I use this tools for that purpose, it expect from user a list of JS payloads to be used in attack, when I set my list that contains 80 lines, just the first 32 lines are took in conderation, I'm trying to solve that problem because 32 payloads are not enough to identify xss vulnerabilities in a webapp with minimal protection, most fuzzing lists contain are least 60 payloads. this is an example – Reda LM Apr 17 '17 at 16:15
  • You need to ask a question. Right now, you're just making a statement, and it's not clear how to help you. "How can I get it to use 80 payloads?" "Why is there a limit?" "Are there better tools?" One of those, or something else, are questions that you might mean to ask. – Mike Caron Apr 17 '17 at 17:32
  • I'm sorry, my question is how can I get it to use 80 payloads ? – Reda LM Apr 17 '17 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.