1

Am trying to run a tor-relay on my raspberry-pi. I have a static IP configured on my pi and enabled the tor service.

But when I tried to do port forwarding for my pi's static ip on my ORport, it is still not visible from the internet. Am using DLINK DSL-2750u router with modified firmware (Middle-East version) so that I can use it as a WAN router (with default firmware it acts as just ADSL modem). Also my ISP provides only dynamic IP address to me.

I verified the same using some online port forwarding checker tools like canyouseeme.org etc. All of them say that my forwarded port is not reachable. I even tried putting my pi on the DMZ, that doesn't seem to work. Has anyone faced this issue? Is there any alternate solution for achieving my purpose? Like using a cheap switch which I can directly connect my PI to the internet?

  • Perform testing with another type of service on your own computer start up a web server or even an SSH daemon on the ports you need for Tor just to confirm connectivity is not the problem. This can cut the problem in half and once you have connectivity working to those ports then troubleshoot the Tor side if it isn't already corrected. Verify that your firewall is allowing the ports you need too. – Trey Blalock Apr 19 '17 at 2:27
  • I guess you already have it but the raspberry pi should have the right gateway to response to the requests to the internet. If you are pretty sure the port is open, check if the raspberry pi is accessing to internet through the same route. – OscarAkaElvis Apr 19 '17 at 6:50
  • Actually Tor's client functionality is working; ie; Rasp-pi is able to establish a Tor circuit from my network to the internet. Am able to connect and browse the web. But my router is blocking connections(tcp/udp) initiated from the internet towards my network. To overcome this I tried to enable port-forwarding and DMZ but in vain :( – Hemanth Apr 20 '17 at 11:31
  • I also checked if my ORport is open and reachable from inside the network. using nmap, nmap shows that my ORport is open and reachable from inside my network, so my router inbuilt firewall is the culprit. – Hemanth Apr 20 '17 at 11:34
  • Don't you need public IP from your ISP enabled to allow outside connections ? – ShinobiUltra Apr 23 '17 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.