1

I'm trying to setup OpenVPN for a LAN, the OpenVPN server is sitting on 192.168.1.99 (Static assigned) on the LAN, the LAN gateway is 192.168.1.254 (ATT400 Router from AT&T), and the subnet is 255.255.255.0.

If I run a hotspot through my Android phone to my MacBook (running Windows 10 Pro on Bootcamp) where I've got the OpenVPN client installed, it will make a connection and assign an IP of 10.8.0.6 (subnet 255.255.255.252). I'm running dev tun on both since dev tap wouldn't work.

I have this command on the server to push the LAN subnet: push "route 192.168.1.0 255.255.255.0"

When I connect though, route print shows nothing for the 192.168.1.0 subnet, and can't ping anything on the subnet.

I looked here and it said:

Next, you must set up a route on the server-side LAN gateway to route the VPN client subnet (10.8.0.0/24) to the OpenVPN server (this is only necessary if the OpenVPN server and the LAN gateway are different machines).

I'm unsure how to do this though. On my router under Firewall I have Packet Filter, NAT/Gaming IP (port forwarding), Passthrough, Firewall Advanced. The advanced just has some options about dropping packets, the passthrough seems to forward all traffic on the router to a host, so I checked under Packet Filter and set up routes from 10.8.0.0/24 to 192.168.1.99 for both TCP and UDP, still doesn't go though. Any ideas?

closed as off-topic by techraf, Steffen Ullrich, schroeder Apr 27 '17 at 6:34

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Information security within the scope defined in the help center." – techraf, Steffen Ullrich, schroeder
If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.