0

When I send a GET request with Burp, it doesn't have "Accept-Encoding" header on it's header. Because of that, I can't get a js file from a website (It returns 406 response).

But when I add "Accept-Encoding: gzip" header manually on Repeater section, application returns 200 response.

I checked Firefox's "about:config" section, it's in default settings.

I installed "Modify Headers" plugin to Firefox, add "Accept-Encoding" header. Still, I Don't see this on my request headers.

I couldn't find any Burp plugin which adds custom header to requests.

How can I solve this issue?

2

Under the proxy options there is a setting "Strip Accept-Encoding headers in incoming requests". Disable this if you want gzip encoded responses.

Burp proxy options

  • wow! yes that's solved the issue – Ivan Todorov May 12 '17 at 7:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.