1

I am very new to Kali, and pen testing, so please correct my terminology if it is off

I have configured the proxy for the firefox browser on the kali linux server to use 127.0.0.1:8080 following the instructions from the support.portswigger.net site.

If i have the proxy set to Auto it will connect to google and any other site fine if i configure it to use 127.0.0.1:8080 it will just spin forever and not make a connection also the tabs in the burp suite do not show any activity

While the browser proxy is still configured to use 127.0.0.1:8080 and i hit an intranet website the proxyand intercepts tabs light up but it says connection closed and once again firefox just spins

How should I configure the firefox proxy locally on the same kali server to be able to get to the internet?

I have been through the steps here:

https://support.portswigger.net/customer/en/portal/articles/2363078-burp-suite-options-upstream-proxy-servers

And here:

https://portswigger.net/burp/help/suite_troubleshooting.html

And everything looks correct.

3

You have probably configured firefox correct, but you have intercept on, in the proxy-intercept tab turn of interception or forward/drop the request.

0

It means the Burpsuite is not listening at the desired interface. Please check the 'Proxy Listeners' tab [Proxy -> Options -> Proxy Options] and ensure the interface 127.0.0.1 is checked. Also ensure the 'intercept' tab is off and you will see the traffic in HTTP history tab.
Next thing will be configure HTTPS site through Burp Suite. Check this article: https://support.portswigger.net/customer/portal/articles/1783075-installing-burp-s-ca-certificate-in-your-browser

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.