3

I've been using Aircrack for a short time now with my Alfa wfif adapter on my laptop and it's been working perfectly. However when I try and do the same thing on my Raspberry Pi it's having issues capturing the WPA2 handshake. As of yet I have not captured a single handshake from my Rasp Pi with all the same hardware. The only difference I can see is that I'm running Raspbian (A version of Debian) on my Rasp Pi.

I've been testing it on my own router that I am sitting right next to so physical distance is not the issue. Everything else works, like deauthing devices, as well as monitor mode, but I'm still not capturing the handshake every time I get on with my phone. Any suggestions on how to fix this issue, or at least where I can start looking for the problem?

closed as off-topic by Steffen Ullrich, Serge Ballesta, Julian Knight, Xander, Steve May 30 '17 at 14:18

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about Information security within the scope defined in the help center." – Steffen Ullrich, Serge Ballesta, Julian Knight, Xander, Steve
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I saw that before. Is a Raspbian driver problem. Which Chipset do you have? – OscarAkaElvis May 25 '17 at 7:39
  • I have an Alfa AWUS036NH the chip set is Ralink RT3070 Here is a link to the info wikidevi.com/wiki/ALFA_Network_AWUS036NH I don't use the built in chipset on the Raspberry Pi because it can't be used in monitor mode. – Sleepy Tiger May 25 '17 at 7:55
  • Curious... I saw the problem with exactly the same Alfa model and chipset. Finally the person (a friend of mine) installed another O.S. on his raspberry and it worked like a Charm (Parrot sec Linux for Raspberry). Anyway, if you don't want to reinstall O.S. You can try to search for driver sources and compile them. Kernel version? Debian version? is jessie? stretch? wheezy? – OscarAkaElvis May 25 '17 at 10:19