0

Details:

I'm running three virtual machines on VMware Workstation:

  • Virtual Machine 1: Windows 7. Using static ip: 10.1.1.1

  • Virtual Machine 2: Windows server 2008. Using static ip 10.1.1.2

  • Virtual Machine 3: Kali Linux. Using static ip 10.1.1.3

They are connected to eachother via a host-only network on VMNet1.

I want to sniff packets going between the two windows machines using Kali Linux's Ettercap.

But when I scan for hosts on the eth0 interface (10.1.1.3) in Ettercap I get the following ip addresses: enter image description here

  • Isn't the VSwitch a level 2 switch? – Leftover May 31 '17 at 20:24
  • I'd want to confirm your network config – schroeder May 31 '17 at 20:29
  • How are you launching the scan? – schroeder May 31 '17 at 20:31
  • I just go to Hosts > Scan for hosts – Leftover May 31 '17 at 20:33
1

It looks like your eth0 connection on your Kali VM has its network adapter setup incorrectly and is actually using your host machine's network (192.168.128.*).

You need to make sure that your VMs are actually using the host-only network.

On your VMs, run ifconfig and check that eth0 is actually on your 10.1.1.* subnet. If it's not, you'll need to double check the eth0 connection setting within your VMs, and that the VMWare network settings for the VMs are correct.

  • ifconfig on Kali Linux outputs: "inet 10.1.1.3 netmask 255.255.255.0 broadcast 10.1.1.255" – Leftover May 31 '17 at 20:32
  • Are you sure there is just one virtual adapter? – Fis May 31 '17 at 20:33
  • Yes. All the machines are connected to the same VMnet1 adapter. – Leftover May 31 '17 at 20:37
  • 1
    And can you ping those two machines? – Fis May 31 '17 at 20:39
  • I ment just eth0 on Kali linux. ifconfig -a – Fis May 31 '17 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.