3

I'm new to Ethical Hacking so please bear with me. What I'm trying to do currently is to crack the password of my personal router using aircrack, wifite and fern wifi cracker.

However, I observed in all three that i am not getting any mac addresses connected to my router or clients that are showing whenever i use aircrack, wifite and the fern tools. I do have multiple devices connected and one of which is my phone, but apparently i'm not able to see any clients in my stuff.

To add up, i'm not sure if my wireless chipset is being supported by these tools. Monitor mode is being enabled, but i'm not sure if this is enough. So far i only know that this is my chipset: Broadcom BCM43xx 1.0 (7.21.171.130.1a1)

Btw, I'm also trying to follow this tutorial: http://lewiscomputerhowto.blogspot.com/2014/06/how-to-hack-wpawpa2-wi-fi-with-kali.html

If you clicked the link I am stuck in step 8. In step 8, I don't see any clients connected to my router, but there are devices connected. I tried both being close and not to distant to my router, but still no luck. I also tried to leave my laptop for 4 hours straight, but still no clients showing up. Not sure if i need to wait for more than that.

For reference, i'm using MacBook Pro 2012. I just use Kali Linux Live via bootable flash drive. For the complete details of my machine, you may refer to this link: https://support.apple.com/kb/SP649?locale=en_US&viewlocale=en_US

  • Have you tried generating traffic on the network in the meantime, letting your phone reconnect with disabling and re-enabling wifi? Are you sure you didn't mistype anything? – Tobi Nary Sep 2 '17 at 9:01
  • Have you tried disconnecting and reconnecting a client to your router? – Polynomial Sep 2 '17 at 11:03
  • Hello @SmokeDispenser! Thanks for commenting on my post! Really appreciate it. Anyway, with regards to that, i just tried turning off my wifi in phone and turn it on again. My phone has the reconnect feature in my personal router, but still no clients showing up. Uhm, yeah, i guess i'm typing the correct commands, i'm just following the commands in the first link above :( – Henry Boco Sep 2 '17 at 12:22
  • Hey there @Polynomial! Thanks for commenting on my post! Appreciate it as well. Yeah, i tried to disconnect my phone's connection in wifi and reconnect, but still no clients showing up :| – Henry Boco Sep 2 '17 at 12:24
  • Sounds a lot like your wireless adapter doesn't support monitor/inject mode. Have you seen and followed this: lewiscomputerhowto.blogspot.com/2014/06/… – Thomas Carlisle Oct 3 '17 at 21:09
1

I've had issues with Broadcom devices in the past, in my experience the driver supposedly supported monitor mode but I couldn't capture traffic over the air.

I'd recommend getting yourself one of the following:

  • Alfa WUS036NH - Ralink chipset
  • TP-Link TP-WN722N - Atheros chipset

Note: Don't bother with the TP-WN722Nv2 it has a Realtek chipset with poor support.

  • Hey what's up @Stu! Thanks for commenting on my post. Anyway, I guess same thing goes to me. It supports the monitor mode, but can't detect some stuff over the air. So you mean i would need to change my wireless adapter in my machine? – Henry Boco Sep 9 '17 at 16:35
  • Yes, I'd recommend getting one of the above two adapters. The TP-WN722N work very well and is smaller than the Alfa card. – Stu Sep 12 '17 at 20:57
  • Hey @Stu! Appreciate your response! Apparently TP-WN722N is already obsolete in stores. I'm currently looking for alternatives right now. I'll try to look for the Alfa you mentioned above. – Henry Boco Oct 1 '17 at 2:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.